Construct PM Web Down
Incident Report for CMiC Cloud
Resolved
This incident has been resolved.
Posted Feb 05, 2024 - 14:09 EST
Identified
We have identified the issue and are working towards resolving it. The mobile app version of Construct PM is functional and this issue is currently affecting the desktop version.
Posted Feb 05, 2024 - 10:53 EST
Investigating
We are currently investigating this issue.
Posted Feb 05, 2024 - 08:59 EST
This incident affected: ATLAS (enterprise.cmiccloudr12.com) (Field) and NOVA (enterprise.cmicr12.com) (Field).