NOVA is back up and running. Please clear your browser's cache and cookies.
Posted Nov 18, 2025 - 09:23 EST
Update
ATLAS was brought back to operational 10 minutes ago. We are working to get NOVA back to operational in the next 10 minutes or so.
Posted Nov 18, 2025 - 09:18 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 09:09 EST
Monitoring
Cloudflare, a leading global security provider, is having a major outage that unfortunately affects CMiC at the moment. According to their status page: https://www.cloudflarestatus.com/ the problem was identified and a fix is being implemented. We are waiting for those changes to propagate fully and CMiC should be back up once that's done.
Posted Nov 18, 2025 - 08:32 EST
This incident affected: NOVA (nova.cmiccloud.com) (System, Enterprise, Field, Reports, Business Intelligence, Mobile Applications, Third-Party Integrations) and ATLAS (atlas.cmiccloud.com) (System, Enterprise, Field, Reports, Business Intelligence, Mobile Applications, Third-Party Integrations, Emails).