Degraded Performance - Cloudflare

Incident Report for CMiC Cloud

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 15:25 EDT

Monitoring

Cloudflare Update:
"Traffic engineering efforts have successfully mitigated the majority of congestion and packet drops. Services are largely stable, with only minor residual impact remaining. A small number of intermittent errors may still be observed for services with origins in North America as we work to fully clear the remaining load."
Posted Jun 22, 2026 - 12:49 EDT

Identified

Cloudflare, a leading global security provider, is facing errors that unfortunately affects CMiC at the moment. According to their status page: https://www.cloudflarestatus.com/ the problem was identified and a fix is being implemented. We are waiting for those changes to propagate fully and CMiC should be back up once that's done.
Posted Jun 22, 2026 - 10:46 EDT
This incident affected: NOVA (nova.cmiccloud.com) (System, Enterprise, Field, Reports, Business Intelligence, Mobile Applications, Third-Party Integrations, Emails) and ATLAS (atlas.cmiccloud.com) (System, Enterprise, Field, Reports, Business Intelligence, Mobile Applications, Third-Party Integrations, Emails).